Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

Version 1 Next »

version 12.4
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname HOST.DOMAIN
!
boot-start-marker
boot system flash:c3825-ipvoicek9-mz.124-22.T5.bin
boot-end-marker
!
card type e1 0 0
card type e1 0 1
card type e1 0 2
logging message-counter syslog
logging buffered 51200 warnings
!
no aaa new-model
clock timezone EST -5
network-clock-participate wic 0 
network-clock-participate wic 1 
network-clock-participate wic 2 
!
dot11 syslog
no ip source-route
ip cef
!
!
!
!
ip domain name SIP.DOMAIN
ip name-server DNS.SERVER.1.IP
ip name-server DNS.SERVER.2.IP
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
isdn switch-type primary-net5
isdn gateway-max-interworking
!
!
trunk group CNC
!
voice-card 0
!
!
voice call send-alert
voice call carrier capacity active
voice rtp send-recv
!
voice service pots 
!
voice service voip 
 sip
!
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
!
!
! This allows for digit manipulation
!  1117 - replaced with 8
!  2228 - replaced with 7
! Used in this example to strip initial 3 digits to route in to 4 digit DID's.
!
voice translation-rule 1
 rule 1 /11111/ /8/
 rule 2 /22222/ /7/
!
!
voice translation-profile profile1
 translate called 1
!
!
username XXXXXXX privilege 15 password 7 XXXXXXXXXXXXXXXXXX
archive
 log config
  hidekeys
!
!
controller E1 0/0/0
 framing NO-CRC4 
 pri-group timeslots 1-31
 description CNC circuit
!
controller E1 0/0/1
 framing NO-CRC4 
 pri-group timeslots 1-31
 description CNC circuit 2
!
controller E1 0/1/0
 framing NO-CRC4 
 pri-group timeslots 1-31
!
controller E1 0/1/1
 framing NO-CRC4 
 pri-group timeslots 1-31
!
controller E1 0/2/0
 framing NO-CRC4 
!
controller E1 0/2/1
!
gw-accounting syslog 
!
!
interface GigabitEthernet0/0
 description INTERFACE DESCRIPTION
 ip address INTERFACE.IP.ADDRESS INTERFACE.SUBNET.MASK
 ip broadcast-address INTERFACE.IP.BROADCAST
 duplex auto
 speed auto
 media-type rj45
!
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 trunk-group OUTBOUND
 no cdp enable
!
interface Serial0/0/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 trunk-group OUTBOUND
 no cdp enable
!
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/1/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 IP.DEFAULT.GATEWAY.ADDRESS
!
no ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
logging SYSLOG.SERVER.IP.ADDRESS
snmp-server community READCOMMUNITY
snmp-server location LOCATION
snmp-server contact EMAIL@ADDRESS
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps tty
snmp-server enable traps config
snmp-server enable traps entity
snmp-server host SNMP.IP.ADDRESS READCOMMUNITY
!
!
control-plane
!
!
voice-port 0/0/0:15
!
voice-port 0/1/0:15
!
voice-port 0/0/1:15
!
voice-port 0/1/1:15
!
ccm-manager fax protocol cisco
!
!
dial-peer voice 100 pots
 translation-profile incoming profile1
 incoming called-number ....
 no digit-strip
 direct-inward-dial
 forward-digits all
!
dial-peer voice 200 pots
 trunkgroup OUTBOUND
 description All outgoing International calls
 service session
 destination-pattern 00.+
 no digit-strip
 forward-digits all
!
dial-peer voice 120 pots
 trunkgroup OUTBOUND
 description All outgoing Long Distance calls
 service session
 destination-pattern 0.+
 no digit-strip
 forward-digits all
!
dial-peer voice 1000 voip
 description sipXecs Range
 service session
 destination-pattern 7...$
 rtp payload-type nte 98
 voice-class codec 1
 session protocol sipv2
 session target dns:SIP.DOMAIN
 dtmf-relay rtp-nte
 no vad
!
dial-peer voice 201 pots
 translation-profile incoming profile1
 service session
 incoming called-number 8080....$
 no digit-strip
 direct-inward-dial
 forward-digits all
!
dial-peer voice 121 pots
 trunkgroup OUTBOUND
 description OutBound Calls
 service session
 destination-pattern .+
 no digit-strip
 forward-digits all
!
dial-peer voice 5000 pots
 trunkgroup OUTBOUND
 service session
 destination-pattern 00...........$
 no digit-strip
 forward-digits all
!
dial-peer voice 1001 voip
 description sipXecs Range
 service session
 destination-pattern 8...$
 rtp payload-type nte 98
 voice-class codec 1
 session protocol sipv2
 session target dns:SIP.DOMAIN
 dtmf-relay rtp-nte
 no vad
!
!
!
line con 0
 logging synchronous
 login local
line aux 0
line vty 0 4
 exec-timeout 120 0
 privilege level 15
 login local
 transport input ssh
line vty 5 15
 privilege level 15
 login local
 transport input ssh
!
scheduler allocate 20000 1000
ntp server NTP.SERVER.IP.ADDRESS
end
  • No labels